Symptoms
- Unable to update WordPress core files and plugins via Smart Update feature at Plesk > WordPress > example.com > Updates > Available > Update with Smart Update. The following error is shown:
Smart Update test run could not be performed due to errors. Address the errors and try running Smart Update again.
Smart Update was unable to correctly clone your website for further analysis. Please try again later.
- During the WordPress updating process with Smart Update, the cloned instance creates a
wpt-fallback-sitemap.xml
file, as can be seen in the Plesk panel log/var/log/plesk/panel.log
with debug enabled:DEBUG Starting: filemng fhceadmin exec /var/www/vhosts/example.com/httpdocs/.wp-toolkit_K timeout 60 /opt/plesk/php/7.0/bin/php -d safe_mode=off -d display_errors=off -d opcache.enable_cli=off -d open_basedir= -d error_reporting=341 -d max_execution_time=60 -c /var/www/vhosts/system/example.com/etc/php.ini /usr/local/psa/admin/plib/modules/wp-toolkit/vendor/wp-cli/wp-cli/php/boot-fs.php --path=/var/www/vhosts/example.com/httpdocs/.wp-toolkit_K --no-color sitemap generate wpt-fallback-sitemap.xml, stdin:
Cause
Product issue:
-
#EXTWPTOOLK-3611 "Smart Updates will now properly work if sitemap of the cloned website differs from the original due to meddling of certain plugins."
Fixed in:- WP Toolkit 4.3.2 24 October 2019
Resolution
Workaround
If update is not possible for some reason, try the following:
workaround
As a workaround, manually create a smart-update-sitemap.xml
and upload it to the instance's Document Root directory:
-
Go to XML-Sitemaps.com website;
-
Enter the website URL (for i.e: https://example.com) to create a sitemap for the instance:
-
Click Start;
-
Click Download your XML Sitemap File Download:
-
When downloaded, rename the file from
sitemap.xml
tosmart-update-sitemap.xml
; - Log in to Plesk;
-
Go to Domains > example.com > File Manager > httpdocs > Upload the
smart-update-sitemap.xml
file.Note: The default Document Root is httpdocs. This can be confirmed at Plesk > Domains > example.com > Hosting Settings > Document Root. In case a custom one is used, upload the file accordingly.