Symptoms
Some of these errors suddenly started affecting a WordPress website hosted in Plesk (after updates, migration, or even if no changes were made):
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The site, or parts of it, won't load, with errors in the browser or dev console
500 external Server Error
503 Service Temporarily Unavailable
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The admin dashboard shows this message
There has been a critical error on your website. Please check your site admin email inbox for instructions
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Disabling all plugins brings the website back up
Cause
Coding issue on the WordPress instance caused by malfunctioning or incompatible plugins, themes and/or customizations.
Resolution
Find out which plugin is causing the issue and disable it.
- Log in to Plesk
- Disable all plugins in WP Toolkit > example.com > Plugins tab
- Enable plugins one by one, checking the site after each one
- When the problematic plugin is identified, disable it and enable the rest
A web developer should review the plugin to find a way to make it work. Possible solutions include reinstalling or updating the plugin, and changing to a different PHP version in case it is not compatible with the current one.