Plesk

When sending mail from Plesk server, DKIM validation failed because the public key is not available after DNS lookup

Symptoms

Cause

There are several possible causes:

Resolution

The following conditions should be met:

  1. The real domain name should be used to send emails from it.

  2. The domain should resolve globally to a correct IP from Plesk. If different IP is detected in the global DNS search, change the domain's DNS Settings.

  3. DKIM-related DNS resource records should be inside of the domain zone.

  4. Disable and enable again mail signing using DKIM in Plesk.

  5. Wait for the DNS propagation period. The changes made will be loaded, applied, and synchronized by DNS (it may take up 48 hours, but mostly faster).

How to check DKIM record

The following commands (same for Linux and Windows) should return the records:

# nslookup -q=TXT default._domainkey.example.com 8.8.8.8
...
default._domainkey.example.com text = "v=DKIM1; p=<DOMAIN'S_DKIM_KEY>"

# nslookup -q=TXT _domainkey.example.com 8.8.8.8
...
_domainkey.example.com text = "o=-"

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