Symptoms
-
A website hosted in Plesk is not accessible with the error:
503 Service Temporarily Unavailable
The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later. -
The following errors examples can be found at
/var/www/vhosts/system/example.com/logs/error_log
:[proxy_fcgi:error] [pid 2915996:tid 140490896815872] [client 203.0.113.2] AH01067: Failed to read FastCGI header
[proxy_fcgi:error] [pid 2915996:tid 140490896815872] (104)Connection reset by peer: [client 203.0.113.2] AH01075: Error dispatching request to : -
In the
/var/log/plesk-php74-fpm/error.log
there are SIGSERV errors related to the example.com pool:WARNING: [pool example.com] child 2146625 exited on signal 11 (SIGSEGV) after 0.058012 seconds from start
Cause
Product issue:
-
#PPPM-13689 "In Plesk on RHEL 8, the Imagick module no longer crashes if gssproxy is installed."
Fixed in:- Plesk Obsidian 18.0.53 06 June 2023 (Linux)
- PHP Updates 16 May 2023 (Linux)
Resolution
Workaround
Please consider updating your server PHP 8.X components and switching the affected domain to any PHP 8.X version
Or:
If update is not possible for some reason, as workaround:
Disable imagick PHP extension
2. Go to Tools & Settings > PHP Settings > Click on the used PHP handler for the affected website. e.g. PHP 7.4.33 Dedicated FPM Application
3. Disable the imagick PHP extension by moving the slider to the left
Once the imagick PHP extension has been disabled, the website should load properly with the PHP version already selected.