Symptoms
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A Customer or Reseller logged into Plesk cannot view the Web Application Firewall button under Websites & Domains > example.com > Security
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The Web Application Firewall button is visible for all domains while logged in as the Plesk Administrator.
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The permission Hosting Settings management is turned off in one of the following locations:
- Plesk > Service Plans > SUBSCRIPTION_SERVICE_PLAN_NAME > Permissions
- Plesk > Resellers > RESELLER_NAME > View More Statistics > Permissions
Cause
The logged in user does not have Hosting Settings management permission enabled which controls the ability to see and manage Web Application Firewall settings.
Resolution
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Log into Plesk as the Plesk Administrator
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Turn on the Hosting Settings management permission accordingly:
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For customer under Plesk > Service Plans > SUBSCRIPTION_SERVICE_PLAN_NAME > Permissions
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For Reseller under Plesk > Resellers > RESELLER_NAME > View More Statistics > Permissions
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Press the Update & Sync button (if it is visible) to save the changes.