Plesk

Upon restoring Plesk backup email messages show backup restoration time as the time they were received on the Apple mail client

Symptoms

Cause

Product issues:

  • #PPPM-10282 Open
  • #PMT-4559 "After migrating mail, actual dates when emails were received are no longer changed to the date of migration on certain mail clients (for example Apple Mail)."
    Fixed in:

Resolution

Please consider updating your server:

Workaround

If an update is not possible for some reason you may try the following

workaround

  1. Connect to the server via SSH.

  2. Download this script to fix the email files timestamp by running the command below:

    # wget https://support.plesk.com/hc/en-us/article_attachments/4407730641426/PMT-4559_mtime_update.sh

  3. Give execution permission to the downloaded script file:

    # chmod +x PMT-4559_mtime_update.sh

  4. Run the script with the target mailbox name:

    # ./PMT-4559_mtime_update.sh jdoe@example.com

    Or multiple mailboxes:

    # ./PMT-4559_mtime_update.sh jdoe@example.com janedoe@example.org

  5. After the script execution is finished, log out and log in back to the mail client and check timestamps.

In some cases, Dovecot indexes might also need to be rebuilt. For this, dovecot index files for each affected mail account should be moved from the default directory.

Note: It should be done separately for each affected account. In the example below, index files are moved for the account jdoe existing for the domain example.com (jdoe@example.com):

  1. Create the destination directory for the index files to be moved:

    # mkdir -p /root/indexback/jdoe

  2. Move the Dovecot index files:

    # mv /var/qmail/mailnames/example.com/jdoe/Maildir/dovecot.index* /root/indexback/jdoe/

  3. Log out and log in back to the mail client.

Exit mobile version