Symptoms
-
Unable to start a migration at Tools & Setting > Migration and Transfer Manager. The following message is shown in Plesk Migrator UI:
Unable to execute command because another migration is in progress
-
The "Starting a migration" step is hung.
Cause
Possible causes:
-
Another migration process is running.
-
Plesk Migrator processes are stuck.
-
Temporary files left after previous processes. Temporary files can be present if the process was crashed or "killed" by a user and thus a cleaning up was not performed properly.
Resolution
If there is another running migration session:
-
Go to Tools & Setting > Migration and Transfer Manager
-
Stop all running migrations or wait for the current subscriptions migration to finish
-
Re-run new migration session
If there are no currently running migration sessions:
-
Go to Tools & Setting > Migration and Transfer Manager
-
Stop all running migrations and remove all sessions by clicking the Finish migration button
-
Connect to the target server via RDP
-
Remove or move out orphaned directories from previous migration sessions:
4.1. Open File Explorer and navigate to the directory%plesk_dir%varmodulespanel-migratorsessions
4.2. If there are any directories inside the directorysessions
remove or move out them -
Kill all possibly hanging processes:
C:> taskkill /T /F /IM python.exe /IM rsync /IM paexec.exe /IM MailMigrator.exe /IM pmmcli.exe
-
Open Plesk > Tools & Setting > Migration and Transfer Manager and start a new mitigation.