Symptoms
-
An attempt to select Atomic Advanced (bought from Plesk) ruleset in ModSecurity fails with the following error:
Failed to install the ModSecurity rule set: modsecurity_ctl failed: gpg: key 4520AFA9: "Atomicorp (Atomicorp Official Signing Key) [email protected]" not changed
...
Authorization failed attempting to download an update.
The username or password may be invalid, or your license may be expired.
...
[1;31m3 303 Core::distributed_update Invalid user credentials
[0m203.0.113.2
stderr:
Unable to download tortix rule set -
Under Tools & Settings > License Management > Additional License Keys licenses for Server and Site Security Pack and Advanced ModSecurity Rules by Atomicorp are shown as installed.
Cause
The license for Advanced ModSecurity Rules by Atomicorp is included in Server and Site Security Pack, so the separate license for ruleset causes the conflict.
Resolution
Remove the license key for Advanced ModSecurity Rules by Atomicorp ruleset. Note: replace Advanced ModSecurity Rules by Atomicorp with Server and Site Security Pack in the instructions below if it's functionality is not required:
- Log in to Plesk.
- Go to Tools & Settings > License Management > Additional License Keys, select the Advanced ModSecurity Rules by Atomicorp license and click Remove.
- Go to Tools & Settings > Web Application Firewall (ModSecurity) > Settings, select any free version and click OK to re-read the configuration
- On Tools & Settings > Web Application Firewall (ModSecurity) > Settings, select the Atomic Advanced (bought from Plesk) ruleset and click OK or Apply button to install the ruleset.
- Contact Plesk Customer Success Team to terminate the license for Advanced ModSecurity Rules by Atomicorp ruleset.