Plesk

Unable to receive emails sent to a specific domain hosted on a Plesk server

Symptoms

Unable to receive emails sent to a specific domain hosted on a Plesk server.

Cause

The affected domain doesn't have a valid DNS MX record/DNS MX record is missing or has no corresponding A DNS record:

# dig @8.8.8.8 +short -t MX example.com +short
10 mail.


# dig @8.8.8.8 +short -t MX example.com +short
(Empty Output)


# dig @8.8.8.8 +short MX example.com
mail.example.com
# dig @8.8.8.8 +short mail.example.com
Empty Output

Resolution

Note: It is required to wait for the DNS propagation period (up to 48 hours, but mostly faster).

If Plesk DNS server is used, add a valid MX/A record for the affected domain.

If DNS records are managed externally, add the appropriate MX records on the registrar's side.

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