Symptoms
-
Emails are not delivered to Plesk with MailEnable mail server.
- It is not possible to send email from the server.
-
The
%plesk_dir%Mail ServersMail EnableQueuesSFOutgoingMessages
folder is missing. -
In
%plesk_dir%Mail ServersMail EnableLoggingSMTPSMTP-Debug-<date>.log
is observed that the message was successfully delivered:ME-I0135: Authenticating User:[email protected] using Authentication Provider Credentials
ME-I0108: [1112] Relay Granted: Sender has authenticated.
ME-I0149: [1112] BD5904B9147A4A03A8CF83F8A4984598.MAI was received successfully and delivery thread was initiated -
The following is shown in
%plesk_dir%Mail ServersMail EnableLoggingMTAMTA-Debug-<date>.log
:ME-MTA-ERROR external Error: (Error 3) Message (AD9A862ABBBC418AA7D5EF5A4F805F6C.MAI) could not be transferred from [SMTP] Connector to [SF] Connector. The message could not be copied to C:pleskMail ServersMail EnableQUEUESSFOutgoingMessages537E8C53A44A4A35BA7DA0ABE8954191.MAI. It has been bad mailed.
Debug 114: Message (AD9A862ABBBC418AA7D5EF5A4F805F6C.MAI) has been copied to the system BadMail directory -
In
%plesk_dir%Mail ServersMail EnableQueuesSFOutgoing
there is a file calledMessages
, which is not a directory.
Cause
The email messages are being received on the server but bad mailed on their way between SMTP and MTA due to a missing directory.
Resolution
-
Connect to the server via RDP
-
Create the missing folder
%plesk_dir%Mail ServersMail EnableQueuesSFOutgoingMessages
as shown below: