Symptoms
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While trying to send an email to a mailbox which is hosted in Plesk, the following bounce back message appears:
The response from the remote server was:
550 5.1.1 [email protected] Recipient not found. http://x.co/irbounceor
550 5.1.1 The email account that you tried to reach does not exist. Please try double-checking the recipient's email address for typos or unnecessary spaces. Learn more at https://support.google.com/ mail/?p=NoSuchUser u5sor6229229vkf.289 - gsmtp
or
(521 No Redirect Entry for this address)
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Third party MX records are configured, for example:
# dig example.com MX
example.com MX 0 smtp.europe.secureserver.net.
example.com MX 10 mailstore1.europe.secureserver.net.
example.com MX 10 aspmx.l.google.com
Cause
3rd-party MX records are configured on the registrar side. Plesk cannot manage mailboxes in such cases.
Resolution
Configure DNS settings to pass mail management to Plesk:
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Remove the following record in Plesk > Domains > example.com > DNS Settings (If such present):
example.com MX 0 smtp.europe.secureserver.net.
-
Create MX record similar to the record below, at Plesk > Domains > example.com > DNS Settings:
- Make sure that the same MX records as from step 2 configured on the registrar side. For example, if DNS is managed by GoDaddy, MX records must be modified on the GoDaddy side.