Symptoms
-
WWW alias, website's subdomain or webmail URL that are hosted in Plesk cannot be opened with the following error:
This site can’t be reached
DNS_PROBE_FINISHED_NXDOMAINOR
This site can’t be reached
ERR_NAME_NOT_RESOLVED -
The main domain
example.com
is accessible without any issues. -
The DNS checker https://mxtoolbox.com/ shows that DNS record for www.example.com, webmail.example.com or one.example.com is not published:
Cause
Missing DNS record (type CNAME) for www.example.com or (type A) for subdomain one.example.com or webmail webmail.example.com.
Resolution
Verify what name servers are used to serve DNS for example.com:
- Go to the online NS record checker (for instance this one: Online tool for NS server check) and find what name servers are used for example.com;
- Check if the NS servers are the same as in the Domains > example.com > DNS Settings (NS records). If they are, then DNS service is managed by Plesk.
If different name servers are used, or the option Domains > example.com > DNS Settings is absent, 3rd party name server provider is used (i.e. DNS provider).
If DNS zone is managed by DNS server in Plesk
-
Go to Domains > example.com > DNS Settings > click Add Record
-
For www.example.com, add a CNAME record:
For one.example.com or webmail.example.com, add an A-record: -
Click the OK button.
If DNS zone is managed by DNS provider
Contact DNS provider (registrar side) to create required CNAME or A-record.