Plesk

Unable to manage permissions in Plesk File Manager: Error: Access is denied. (Error code 5) at GetTempFileName in C:WindowsTEMP

Symptoms

Cause

Some user groups do not have enough permissions on C:windowstemp directory, thus, fails to create temporary files in there from services that need it.

Resolution

Add the necessary permission on C:windowstemp:

  1. Connect to the server via RDP;

  2. Right-click C:windowstemp, go to Properties > Security (tab) > Advanced > select Users > click Edit, toggle the following two permissions:

    • Create files / write data
    • Create fodlers / append data

  3. Check if there are any "Deny" rules for other groups

  4. Switch them to "Allow"

  5. Click OK.

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