Symptoms
-
Unable to login at Plesk with user admin. The following error is shown:
Unable to find row by field login with value admin in smb_users table.
-
Unable to manage a subscription at Plesk > Subscriptions > example.com. The following error is shown:
Unable to find row by field login with value username in the smb_users table
-
The following MySQL query gives an empty output:
mysql> SELECT smb_users.* FROM smb_users WHERE (login = 'admin');
Empty set (0.01 sec)
Cause
Database inconsistency: User information is not recorded in psa
database.
Resolution
In case Plesk 'admin' user is affected and Plesk user interface is available:
- Log into Plesk;
- Go to My Profile (left-hand side) > Profile & Preferences;
- Click OK:
In case Plesk 'admin' user is affected but Plesk login is unavailable:
- Log in to the server through SSH;
-
Execute:
# /usr/local/psa/bin/init_conf -u -name Admin
In case a customer is affected:
- Log into Plesk;
- Go to Customers > jdoe > Add description.
- Modify the description with any changes. Revert the changes if required: