Symptoms
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When logging in to Roundcube/Horde webmail, the login fails with:
Connection to storage server failed.
or the page loads for some time and then shows:
external Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request. -
The Dovecot service fails to start. The following error message appears in
/var/log/maillog
or in the service status:dovecot: config: Fatal: Error in configuration file /etc/dovecot/conf.d/14-plesk-sni-example.com.conf line 7: ssl_cert: Can't open file /usr/local/psa/var/certificates/scfNkZxBn: No such file or directory
Cause
The SSL certificate file for securing domain's mail does not exist in the system.
Resolution
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Connect to the Plesk server via SSH.
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Check if the domain from the error message exist in Plesk with the command:
# plesk bin site --list | grep example.com
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Repair SSL certificates:
# plesk repair web -sslcerts
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Restart the Dovecot service:
# service dovecot restart
If the service still fails to start, apply the following steps:
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Go to Domains > example.com > Mail Settings.
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Set the option SSL/TLS certificate for mail to "Not selected" and apply the changes.
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Select SSL certificate back and apply the changes.
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Remove the orphaned configuration files:
Note: Replace example.com with the domain name from the error message.
# rm -f /etc/dovecot/conf.d/14-plesk-sni-example.com.conf
# rm -f /etc/dovecot/conf.d/14-plesk-sni-mail.example.com.conf
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Check Dovecot configuration:
# dovecot -F
-
Restart the Dovecot service:
# service dovecot restart