Plesk

Unable to log in to Plesk: 500 Session_exception. Unable to set up default locale: default locale does not exist or undefined

Symptoms

Cause

Corrupted locale files.

Resolution

  1. Connect to the server via RDP.

  2. Download the latest version of package plesk-locale-base-en-US.msi from the Windows repository https://autoinstall-win.plesk.com/pool/release/:

    1. Select the last directory in the list - that would be the latest Plesk version
    2. Open the dist-windows/ directory
  3. Make a backup of %plesk_dir%adminapplication and %plesk_dir%adminplib directories.

  4. Create a temporary directory for extracting the plesk-locale-base-en-US.msi package (for example, C:locales)
  5. Open the Command Prompt and extract the package files to a temporary directory using the following commands:

    Note: this example assumes that the package has been downloaded to C:UsersAdministratorDownloads. Replace it with the actual package's path if the download location was different

    C:> cd C:UsersAdministratorDownloads

    C:>msiexec /a "plesk-locale-base-en-US.msi" /qb targetdir=C:locales

  6. Copy the extracted files and directories from C:locales to %plesk_dir%adminapplication and %plesk_dir%adminplib, replacing old data.

  7. Reinstall any missing Plesk components:

    C:>plesk installer update

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