Symptoms
-
Unable to list APS applications for a domain with the error:
Search results could not be loaded at the moment
-
Unable to upgrade Plesk:
Unable to find "main" IP address in "psa" database.
-
The following error can be found in
/var/log/sw-cp-server/error_log
file:ERR (3): APS Catalog error: Unable to define main IP address
Cause
Product issue:
-
#PPPM-11484 "Re-reading IP addresses on the server no longer results in the same IP address being displayed twice (with and without the “Main IP address” flag in Plesk under specific circumstances."
Fixed in:- Plesk Obsidian 27 October 2020 (Linux)
- Plesk Obsidian 15 September 2020 (Linux)
- Plesk Obsidian 12 May 2020 (Linux)
- Plesk Obsidian 17 March 2020 (Linux)
Resolution
Workaround
Apply one of the following solutions:
Via Plesk GUI
- Log into Plesk.
- Go to Tools & Settings > IP addresses.
- Press the Reread IP button.
Note: in case the solution did not help, use the steps from the "Via server access" section.
Via Server access
- Connect to the server via SSH.
- Run the following command:
# /usr/local/psa/bin/ipmanage --reread
-
If the solution above did not help, apply the solution below:
-
Create a backup of
database:
psa
# plesk db dump psa > psa.sql
-
Connect to
database in MySQL console:
psa
# plesk db
-
Change the value of main to true for one of the IP addresses:
mysql> UPDATE IP_Addresses set main='true' WHERE ip_address='10.10.10.10';
Note: replace the IP Address 10.10.10.10 with yours one.
-