Plesk

Unable to issue/renew a Let’s Encrypt certificate in Plesk: Error creating new account :: “” is not a valid e-mail address

Symptoms

Cause

The email address of the subscription owner is not set at Domains > example.com > Subscription Info (in the right pane) > Subscriber: John Doe > Edit Contact Info (in the right pane):

Resolution

  1. Log in to Plesk.

  2. Go to Customers > John Doe > Edit Contact Info (in the right pane) and set an email address for this customer.

    Note: The email address used for Let's Encrypt certificate notifications can be set to another one when issuing a Let's Encrypt certificate.

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