Symptoms
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After updating Plesk Obsidian to version 18.0.40, Acronis backup fails with the following error:
Failed to execute command '/usr/lib/Acronis/BackupAndRecovery/webcpprecapture: /usr/bin/sw-engine: /usr/lib/Acronis/system_libs/8.2.1/libstdc++.so.6: version `GLIBCXX_3.4.26' not found (required by /usr/bin/sw-engine)
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Acronis console shows the following error message:
Cannot protect a device with assigned quota
Protection plan 'webcp' has been revoked from 'server.example.com' due to a licensing issue.
Cause
Acronis agent bug has been fixed in Acronis agent version 15.0 28610.
Resolution
Update Acronis agent using the steps below:
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Go to Acronis Backup > Go to backup console. Enter credentials from the Acronis Backup console if required.
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In the Acronis Backup console go to Settings > Agents.
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In the list of machines select the one with outdated agent versions. They will be marked with an orange exclamation mark.
Note: The machines must be online.
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Click Update agent. After updating make sure there are no unset directives that were previously configured as follows 69808: Acronis Backup extension for Plesk: Backup fails after Plesk update to version 18.0.40:
If update is not possible for some reason, apply
manual workaround:
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Connect to the Plesk server via SSH.
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Open the file
/usr/lib/Acronis/BackupAndRecovery/webcpprecapture
in a text editor. In this example, we are using the vi editor:# vi /usr/lib/Acronis/BackupAndRecovery/webcpprecapture
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Add the following lines:
unset LD_LIBRARY_PATH
unset LD_PRELOAD -
Save the changes and close the file.
Apply the following steps additionally, if Acronis agent version is 28323 (version can be checked in Acronis console).
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Connect to the Plesk server via SSH.
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Download the patched
libwebcp_agent.so
file:# wget https://plesk.zendesk.com/hc/article_attachments/12376927359895/libwebcp_agent.so
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Rename the original file:
# mv /usr/lib/Acronis/BackupAndRecovery/libwebcp_agent.so /usr/lib/Acronis/BackupAndRecovery/libwebcp_agent.so_backup
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Move the downloaded file to the Acronis directory:
# mv libwebcp_agent.so /usr/lib/Acronis/BackupAndRecovery
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Restart the Acronis service:
# service acronis_mms restart
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Verify that Plesk is detected using the command:
Note: It make take a couple of minutes to take effect.
# acropsh -m dmldump -s mms -vs InstanceManagement::Instance | grep InstalledApplication
('.Parameters.InstalledApplication', 'item_string', 'Plesk'),
('.Parameters.InstalledApplication^Searchable', 'nil', None),