Plesk

Unable to change the type of an IP address in Plesk for Windows Server: Cannot connect to the task manager (plesk-task-manager service might not be running)

Symptoms

Cause

Plesk Task Manager requires the nssm service which fails to be installed or its installation is broken. This may happen when antivirus/firewall blocks it.

Resolution

Note: Exclude the Plesk folder %plesk_dir% (by default, C:Program Files (x86)Plesk) from antivirus/firewall scans or disable antivirus/firewall temporary.

  1. Connect to the Plesk server via RDP.

  2. Go to C:ProgramDataPleskInstallercachepoolrelease and search for "plesk-nssm.zip.tmp". If the .tmp file is found, rename it.

  3. Download the package plesk-nssm.zip from autoinstall-win.plesk.com ( > PANEL-WIN_18.0.XX > dist-windows). 

  4. Unzip the package and copy the files to C:Program Files (x86)Plesknssm.

  5. Install Plesk Task Manager:

    C:> "%plesk_dir%adminbindefpackagemng.exe" --update --type=psa.task-manager --package=task-manager --fix

  6. Verify that the PleskTaskManager is installed:

    C:> sc query "PleskTaskManager"

    SERVICE_NAME: PleskTaskManager
    ...
            STATE : 4 RUNNING

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