Plesk

Unable to access subscription: Access to the location account/switch is denied

Applicable to:

  • Plesk for Linux

Symptoms

Cause

Missing entries in the Plesk database.

Resolution

1. Connect to the server via SSH
2. For security reasons backup the Plesk database:

# plesk db dump psa > /root/psa_backup.sql

3. Check the ID of the reseller:

# plesk db "select login, roleID from smb_users where login='reseller_name'"
+-------------------------------+--------+
| login                         | roleID |
+-------------------------------+--------+
| reseller_name                 |    3   |
+-------------------------------+--------+

4. Run the following command to create permissions for the reseller with ID from the step 3:

# for i in {1..18}; do plesk db "insert into smb_roleGeneralPermissions (roleId,generalPermissionId,isAllowed) VALUES (3,$i,1)"; done

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