Plesk

Unable to access Plesk: The number of websites hosted on the server exceeds the limits defined by your license

Symptoms

Cause

Web Host license used previously had unlimited number of domains. Once new license exceeds the domain limit (10 domain for Web Admin or 30 domains for Web Pro), these domains become invisible in Plesk interface and it is not possible to manage them there.

Resolution

To resolve the issue, the license can be upgraded to the type which covers required number of domains. For example, if you have only up to 30 domains, you can change license from Web Admin (10 domains) to Web Pro (30 domains). Alternatively, it is possible reduce the number of domains to the allowed limit:

Using Plesk GUI

  1. Obtain a trial license;

  2. Log into Plesk;

  3. Go to Tools & Settings > License Management and install the trial license key;

  4. Go to Plesk > Websites & Domains and remove unnecessary domains;

  5. Once the number of domains does not exceed the limit of the license - install the purchased license in Tools & Settings > License Management > Install Key.

Using the command line

  1. Obtain a trial license;

  2. Connect to the server via SSH/RDP;

  3. Install the trial license;

    # plesk bin license -i XXXXXX-XXXXXX-XXXXXX-XXXXXX-XXXXXX

  4. List all domains on the server (for both Windows and Linux OS):

    # plesk bin domain --list
    # example.com
    # example.net

  5. Remove domains using command line:

    # plesk bin domain --remove example.net

  6. Install the purchased license:

    # plesk bin license -i XXXXXX-XXXXXX-XXXXXX-XXXXXX-XXXXXX

 

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