Plesk

Unable to accept or send emails on Plesk server via SendGrid with forwarding enabled: 550 The from address does not match a verified Sender Identity.

Cause

With forwarding enabled in Plesk, the "from" header uses the original sender email address, but SendGrid expects the forwarder domain name in this header. Hence, SendGrid is rejecting mail.

It is expected behavior in Plesk for the forwarding to use the original "from" email address.

Resolution

One of the following options is available for forwarding emails with SendGrid:

  1. Configure forwarding in webmail or mail client interface - the instructions will vary depending on a particular webmail/mail client software. It works differently and will use another "from" header, meaning that it should be accepted by SendGrid.

  2. Contact SendGrid support and clarify if they can suggest any options to allow/verify email, keeping in mind that "from" header contains an address different from the verified domain because of forwarding.

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