Plesk

The message “Connection error” appears in Plesk 360 for a server behind Cloudflare

Symptoms

Cause

Connection fails since at the moment Plesk service on port 8443 does not support restoring original visitor IPs for Cloudflare since sw-cp-server is compiled without http_realip_module.

Resolution

Disable restrictions

  1. Remove the server from Plesk 360 > Servers

  2. Add it again but disable the restrictions:

Workaround

  1. Create a domain for Plesk UI specifically (e.g. server.example.com)

  2. Under Tools & Settings > Customize Plesk URL, select The specified domain or subdomain that resolves to the server IP address but is not used for hosting and put server.example.com

  3. Enable restoring original visitor IP in accordance with the article below (the section Server-wide solution with Nginx enabled):
    Incorrect IP addresses logged by Plesk behind load balancer, or reverse/forward proxy

  4. Make sure that Plesk URL can be accessed via https://server.example.com, and it is secured with a valid certificate (Cloudflare should do that automatically)

  5. Try to re-connect the server to Plesk 360 by using https://server.example.com (without port 8443)

Exit mobile version