Symptoms
The following error is shown when attempting to open Plesk interface or update a license key:
Error: The license key is invalid. In order to use Plesk, you need to obtain and install a new valid license key.The license key is intended only for use with Plesk operating inside the following virtual environments: Virtuozzo containers, VMWare, Microsoft Hyper-V, Xen, KVM, Virtuozzo Server, LXC, Docker.
Cause
Virtual environment is not supported, for example:
- Plesk is installed on a not supported virtualization environment;
- A misconfigured virtual machine is detected as physical host;
- limits on virtual container;
- The license is being installed on a dedicated server instead of VPS.
Resolution
Plesk supports only the following virtualization solutions:
- VMware
- XEN
- Virtuozzo (former Parallels Cloud Server 6)
- OpenVZ
- Virtuozzo containers 4.6 for Linux
- Virtuozzo containers 4.6 for Windows
- Virtuozzo containers 4.7 for Linux
- LXC (Docker)
- KVM
- Hyper-V
If the virtualization environment is not supported, upload a dedicated Plesk license, not a VPS one.
Switch license type from for VPS to Dedicated server by logging into platform360.io and clicking upgrade button (Only if license purchased is Web Pro or Web Host)
To see how Plesk detects the environment it runs in, use either of the following methods:
-
Windows:
C:>"%plesk_bin%php.exe" -dauto_prepend_file= -r "echo get_virtualization();"
-
Linux:
# systemd-detect-virt
-
On Linux, other utilities you can use (not related to Plesk) include
dmidecode
andlspci
. -
Additionally, on Windows, the following steps may be followed to get BIOS information:
-
Run
wbemtest
in the command line. -
Click Connect twice.
-
Click Query.
-
Execute:
mysql> SELECT * FROM Win32_BIOS
If this results in BIOS information similar to
Version='ACRSYS - 1'
, the BIOS was hacked and the hack should be deactivated, or the license for Dedicated servers needs to be obtained.If the output suggests the lack of a virtual platform, there is no other way to make Plesk detect it other than to re-deploy it properly with the correct settings.
-
-
Make sure that Plesk Management Service is up and running. Restart Plesk management services:
-
Windows:
Login into server as Administrator Start menu > All programs > 'plesk services monitor' > Restart 'Plesk Management Services'
-
Linux:
# /etc/init.d/psa stop $ /etc/init.d/psa start
-
-
Confirm it using below command on the server:
C:> "%plesk_bin%php.exe" -dauto_prepend_file= -r "echo get_virtualization();"
xen
Note: If this article did not help, check /usr/local/psa/admin/logs/panel.log
file for exact error when trying to install or retrieve a license. If there are "Fork failed - Cannot allocate memory" errors found in panel.log
, visit: Error: Fork failed - Cannot allocate memory