Symptoms
-
Subscription
example.com
does not appear in the Subscriptions list in Tools & Settings > Migration & Transfer Manager > List of subscriptions during the migration from cPanel to Plesk. -
Subscription
example.com
belongs to resellerroot
or any other existing reseller in cPanel > Resellers > Show Reseller Accounts.
Cause
cPanel misconfiguration; system user of the subscription belongs to non-existing reseller according to /etc/trueuserowners
file in cPanel server:
# grep example /etc/trueuserowners
example: jdoe
Resolution
Note: the steps 1-6 are done on the cPanel server. If you experience any difficulties with these steps contact cPanel support directly.
-
Connect to the cPanel server via SSH.
-
Create a backup of the configuration file:
# cp -a /etc/trueuserowners{,.bak}
-
Modify file
/etc/trueuserowners
and set the current reseller name to the subscription user:Before:
example: jdoe
After:
example: root
-
Log in to the cPanel.
-
Go to Account Functions > Modify an Account. Select
example.com
and press Modify. -
Press Save without any changes.
-
Go to Tools & Settings > Migration & Transfer Manager > List of subscriptions and press Reload Source Data.
-
Select "example.com" from the list and press Migrate.