Plesk

Site on Plesk shows Apache default page: no index file

Symptoms

Cause

There is no index file in the Document Root of the domain, or the expected file has a typo in the name.

Resolution

  1. Log in to Plesk.

  2. Go to Domains > example.com > File Manager and check if there is an index file of the website.

  3. Create index file in the document root directory with required content or specify custom index file under Domains > example.com > example.com > Apache & nginx Settings > Common Apache settings > Index files for the existing one to be recognized:

    Alternatively, specify the document root under Domains > example.com > Hosting Settings to point to the directory that contains the index file.

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