Symptoms
-
A lot of services (e.g. MailEnable) are periodically down.
-
In Event Viewer > System below can be found:
The MailEnable IMAP Service service terminated unexpectedly. It has done this 1 time(s).
The MailEnable SMTP Connector service terminated unexpectedly. It has done this 1 time(s).
The MailEnable Mail Transfer Agent service terminated unexpectedly. It has done this 1 time(s).
The MailEnable SMTP Connector service terminated unexpectedly. It has done this 5 time(s).
The MailEnable POP Service service terminated unexpectedly. It has done this 3 time(s).
The DrWebCom service terminated unexpectedly. It has done this 1 time(s).
The MySQL56 service terminated unexpectedly. It has done this 2 time(s). -
2004
event ID can be found prior to this:Windows successfully diagnosed a low virtual memory condition. The following programs consumed the most virtual memory: lsass.exe (700) consumed 763445248 bytes, w3wp.exe (928) consumed 592650240 bytes, and cdp.exe (4616) consumed 539738112 bytes.
Event id 2004
Source Resource-Exhaustion-Detector -
In Event Viewer > Application, the following error can be found, related to the failed service:
General: (MailEnable SMTP Service (C:Program Files (x86)ParallelsPleskMail ServersMail EnableBin64MESMTPC.EXE) error: 0) SendSMTPMessage handled an exception; session will be dropped.
-
When starting services via Plesk Service Monitor, they crash with the
System.OutOfMemoryException
error.
Cause
Lack of RAM or CPU resources.
Resolution
Check server performance. There should be always enough free memory, and server must not be under high load. Advanced Monitoring extension can help track resources.