Plesk

Scan fails in WP Toolkit: Failed to reset cache for the instance #34: Error: This does not seem to be a WordPress installation.

Symptoms

Scan fails in WP Toolkit with the error:

Scanning for WordPress websites was performed with errors:
Subscription "example.com": Failed to reset cache for the instance #34: Error: This does not seem to be a WordPress installation. Pass --path=`path/to/wordpress` or run `wp core download`.

Cause

Information about the WordPress instance exists in WP Toolkit database.

Resolution

  1. Connect to the Plesk server via SSH.

  2. Create a backup file of the wp-toolkit.sqlite3 database:

    # cp /usr/local/psa/var/modules/wp-toolkit/wp-toolkit.sqlite3 /usr/local/psa/var/modules/wp-toolkit/wp-toolkit.sqlite3.bak

  3. Open WP Toolkit database

    # sqlite3 /usr/local/psa/var/modules/wp-toolkit/wp-toolkit.sqlite3

  4. Remove the orphaned records using the instance ID from the error message:

    sqlite> .headers on

    sqlite> delete from instanceProperties where instanceId = 34;

    sqlite> delete from instances where instances.id = 34;

    sqlite> .quit

 

 

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