Symptoms
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License is in grace period even though it was updated/renewed correctly on a licensing server side:
Warning: You are currently operating within the grace period of your product license. To update your product license, select the Retrieve Keys option on the License Management page.
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While trying to retrieve/install keys at Plesk > Tools & Settings > License Management (Plesk > Tools & Settings > Server information) the page loads forever until it fails with:
504 Gateway Timeout
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The same error may appear when trying to log into Plesk.
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After enabling debug, in
/var/log/plesk/panel.log
it can be seen that the license update stops on the following step:DEBUG [util_exec] [5af1e640d2247] Starting: sysinfo df-full, stdin:
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The following
df (disk free)
processes can be found:# ps aux | grep df
root 6806 0.0 0.0 18356 2012 ? S 06:46 0:00 /usr/local/psa/admin/bin/sysinfo df-full
root 7229 0.0 0.1 18356 4416 ? S 06:48 0:00 /usr/local/psa/admin/bin/sysinfo df-full
<..>
root 11409 0.0 0.1 18356 4424 ? S 12:55 0:00 /usr/local/psa/admin/bin/sysinfo df-full
root 13955 0.0 0.1 18356 4420 ? S 12:57 0:00 /usr/local/psa/admin/bin/sysinfo df-full -
df -h command hangs
Cause
The "df" utility processes are hung (for example due to bug in CentOS / RedHat 7.5 in CentOS 7.5, however Ubuntu operating system might be affected too) causing Plesk services to hang too.
The issue is also registered as Plesk bug PPPM-8614 which is planned to be fixed in future product updates.
Resolution
Note: it is not recommended to kill the stuck df processes.
Reboot the server to fix df command related issue. All Plesk services will work correctly when df command can be executed normally.