Symptoms
-
RAM is not calculated in the Repair Kit. The following error is provided instead under the RAM section:
Can not retrieve information about memory usage:
Completed only 0 of 4 bytes at (Con::OverlappedPipe::externalComplete line 392) at Unable to call readMessage() (RunTume::PipeClient::readMessage line 122) at execUtil("C:Program Files (x86)Pleskadminbin64repairmng.exe" --get-system-resources) (PleskRepair::DefaultSystemHelper::execUtil line 45) at Repair action 'repairmng.exe --get-system-resources' execution failed(PleskRepair::ExecUtilAction::execute line 33)
Cause
Corrupted repairmng.exe
file.
Resolution
-
Connect to the server via RDP.
-
For security reasons copy the current
C:Program Files (x86)Pleskadminbin64repairmng.exe
file to any directory, for example, to the Desktop. -
Create a temporary directory on a Desktop named 'Backend'. Its full path will be:
C:UsersAdministratorDesktopBackend
. -
Switch to the directory where Plesk MSIs are stored. It's located in
C:ProgramDataPleskInstaller...
or inC:ParallelsInstaller...
.
Select the latest version of Plesk available in the directory. The command should be like below:C:> cd C:ProgramDataPleskInstallercachepoolreleasePANEL-WIN_18.0.XXdist-windows
-
Unpack the
plesk-backend.msi
from this directory to the temporary folder created on step 3:C:> msiexec /a plesk-backend.msi /qb TARGETDIR=C:UsersAdministratorDesktopBackend
-
Replace the original
C:Program Files (x86)Pleskadminbin64repairmng.exe
file with the one from the unpacked MSIC:UsersAdministratorDesktopBackendProgram FilesParallelsPleskadminbin64repairmng.exe
:C:> copy "C:UsersAdministratorDesktopBackendProgram FilesParallelsPleskadminbin64repairmng.exe" "C:Program Files (x86)Pleskadminbin64repairmng.exe"