Plesk

Plesk WP website is not accessible with the 403 Forbidden error after a WooCommerce plugin update

Symptoms

Cause

Comodo rule with ID 218500 is triggered when Woocommerce 8.5 is in use.
Woocommerce is working to avoid this rule being triggered.

The lines below can be found in Domains > example.com > Logs:

ModSecurity: Warning. Pattern match "[[]x22',().]{10}$|b(?:unionsallsselects(?:(?:null|d+),?)+|ordersbysd{1,4}|(?:and|or)sd{4}=d{4}|waitforsdelays'd+:d+:d+'|(?:select|and|or)s(?:(?:pg_)?sleep(d+)|d+s?=s?(?:dbms_pipe.receive_message ..." at REQUEST_COOKIES:sbjs_first. [file "/etc/httpd/conf/modsecurity.d/rules/comodo_free/22_SQL_SQLi.conf"] [line "66"] [id "218500"] [rev "18"] [msg "COMODO WAF: SQLmap attack detected||example.com|F|2"] [data "Matched Data: |||id=(none) found within REQUEST_COOKIES:sbjs_first: typ=organic|||src=google|||mdm=organic|||cmp=(none)|||cnt=(none)|||trm=(none)|||id=(none)"] [severity "CRITICAL"] [tag "CWAF"] [tag "SQLi"] [hostname "example.com"]

Resolution

As a workaround before changes on WooCommerce plugin side:

  1. Log into Plesk.
  2. Disable rule with ID 218500 for the affected domains as per the following article.
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