Symptoms
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Website preview does not work with Quick Preview on an external domain name option selected under Tools & Settings>Website Preview. The following errors are displayed by the browser:
This site can't be reached
<URL>'s server IP address could not be found.
Try running Windows Network Diagnostics.
DNS_PROBE_FINISHED_NXDOMAIN
Cause
DNS service for the domain in question is not being managed in Plesk or the corresponding A record is missing. In order for Site Preview to work out of the box, a domain must have its DNS served by Plesk or have corresponding A record.
Resolution
Apply one of the following solutions:
Use Plesk as the DNS server
Set DNS records manually
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In Plesk, go to Tools & Settings > Website Preview select the option Quick Preview on an external domain name and specify the name of the domain to be used for site preview.
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In the DNS server, configure an “A” DNS record for that domain. The record should look like this:
*.<Plesk_IP>.<domain_name>.
where <domain_name> is the name of the domain, and <Plesk_IP> is the IP address of the Plesk server with dots(.) for IPv4 or colons (:) for IPv6 are replaced with dashes (-). For example, Plesk IP address is 192.168.10.20, and the name of the domain is example.com, the “A” record will look like this:
*.192-168-10-20.example.com.
If there is more than one IP address registered in Plesk, add a corresponding record for each of them.