Plesk

Plesk update/installation fails: The MD5 checksum of the plesk-nssm.zip.tmp file does not match the value specified in the configuration file

Symptoms

Plesk update/installation fails with one of the following error messages:

The MD5 checksum of the C:ProgramDataPleskInstallercachepoolreleasePLESK-WIN_18.0.39_7267dist-windowsplesk-nssm.zip.tmp file does not match the value specified in the configuration file.


Downloading file pool/release/PLESK-WIN_18.0.54_12327/dist-windows/plesk-nssm.zip: Recv failure: Connection was reset. Will retry in 3 second(s)...

Cause

The file plesk-nssm.zip.tmp is corrupted. This may happen when antivirus/firewall blocks it.

Resolution

  1. Connect to the Plesk server via RDP.

  2. Go to C:ProgramDataPleskInstallercachepoolrelease and search for "plesk-nssm.zip.tmp". If found, remove this .tmp file.

  3. Download the package plesk-nssm.zip from autoinstall-win.plesk.com (> PANEL-WIN_18.0.XX > dist-windows).

    Note: If the download fails, contact network administrator of the server to check why the download of plesk-nssm.zip.tmp failed.

  4. Copy the package to C:ProgramDataPleskInstallercachepoolreleasePLESK-WIN_18.0.XX_XXXXdist-windows (choose the latest file version).

  5. Rerun Plesk update/installation:

    # plesk installer update

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