Symptoms
- Plesk upgrade to Obsidian fails or gets stuck with one of the following errors:
Upgrading Plesk Engine...
Failed service operation: This operation returned because the timeout period expired. (Error code 1460) at Start service PleskWebSocket
Sub-action 'ServiceControl' failed with error code: 1064(0x00000428)
Upgrading Plesk core sources...
Error occured while performing sub-action 'UpgradeZip': Unable to create temporary directory for update in root folder: C:Program Files (x86)Pleskadminhtdocsmailconfig
-
Plesk may not be accessible after the upgrade attempt.
-
3rd party Anti-virus solution(s) (AVG, Malwarebytes Premium, etc) enabled on the server.
Cause
Anti-virus solution(s) blocks the Plesk upgrade process.
Resolution
-
Connect to the server via RDP.
-
Reboot the server in order to kill any stuck processes.
-
Disable Anti-virus solution(s).
-
Re-run Plesk upgrade process.
C:> "%plesk_bin%"ai.exe --console