Plesk

Plesk migration fails or website not accessible: There is a duplicate section defined

Symptoms

Cause

There is a duplicate section in the web.config file and in the upper-level configuration file.

Resolution

  1. Log in to source Plesk panel
  2. Go to Domains > example.com > File Manager

  3. Open the file mentioned in the error message using a text editor and comment out the duplicate line of the mentioned number by
    <!-- at the beginning
    and --> at the end of the line.
    For example:

    <!-- <sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=*********"> -->

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