Symptoms
-
The product license fails to update. The following errors may occur:
Licensing Server Unreachable: Unable to connect with licensing server.
Please make sure that your network allows communication to ka.plesk.com:5224.
For more details check system help pages.
Couldn't resolve host name
Can't connect to ka.plesk.com:5224 (Timeout)
Could not update the license. Make sure that connections to the license server
ka.plesk.com
on TCP port 5224/443 are not blocked. See how to do so. -
The
curl ka.plesk.com:443
command fails with one of the following errors in/var/log/plesk/panel.log
:# cURL cannot communicate with license server https://id-X2.kaid.plesk.com:443/ (): Couldn't resolve host name(6)
# cURL cannot communicate with license server https://id-X2.kaid.plesk.com:443/ (195.214.233.80): Timeout was reached(28)
# cURL cannot communicate with license server https://id-X2.kaid.plesk.com:443/ (195.214.233.80): Couldn't connect to server(7)
Cause
Plesk tries to connect to the license server ka.plesk.com on TCP ports 5224 or 443 to update the license, but cannot establish a connection.
Since February 5, 2018, ka.plesk.com
hostname will be resolved into 3 different IP addresses based on round-robin logic:
195.214.233.80 (old one)
195.214.233.81 (new)
195.214.233.82 (new)
Additionally, since the same date, the Key Administrator will accept connections from Plesk on two ports :
5224 (an old one, non-standard port)
443 (new, default HTTPS port)
Resolution
-
Check whether ka.plesk.com resolves to one of the proper IP addresses:
# nslookup ka.plesk.com
Non-authoritative answer:
Name: ka.plesk.com
Address: 195.214.233.80If not, check that the
/etc/hosts
file (for Linux) orC:WindowsSystem32driversetchosts
file has no records withka.plesk.com
.
Specify one of the IP addresses forka.plesk.com
there, e.g.:195.214.233.81 ka.plesk.com
-
Use the following command to check the connectivity:
# telnet ka.plesk.com 443
In case a connection is successful, the output is as follows:
# telnet ka.plesk.com 443
Trying 195.214.233.81...
Connected to ka.plesk.com.
Escape character is '^]'.
^]Note: Telnet client should be installed additionally for Windows.
If
ka.plesk.com
resolves to the right IP address, but the connection still fails, check whether outgoing connections are blocked by firewall.
Check the DNS resolver configuration. -
As a temporary workaround, upload a file with the license to the server and install it from a command line (command is applicable for both Windows and Linux):
# plesk bin license -i path_to_license_file