Symptoms
Plesk panel is not accessible with the following error:
Exception: Unable to get PSADb administrator password: The system cannot find the file specified. (Error code 2) on Cannot connect to pipe
Plesk Management Service is absent from the Services list in Windows or it cannot be started
Cause
The Plesk Management Service is corrupted or misconfigured
Resolution
Connect to the server via RDP.
Check whether the
plesksrv.exeis present in%plesk_bin%directory and apply the appropriate steps:
If the plesksrv.exe file is present
1. Start the command prompt as the Administrator
2. Run the following commands to reinstall the missing service:
cd %plesk_bin%
plesksrv -install
If the plesksrv.exe file is missing
1. Start the command prompt as the Administrator
2. Run the following command to create a temporary directory for extracting the MSI package:
mkdir C:pleskmsi
3. Find the Plesk Installer directory - it can be either of these two locations:
C:ProgramDataPleskInstallercachepoolrelease
C:ParallelsInstallercachepoolrelease
4. Switch to the current Plesk version's directory via CMD. In the example below, path for Plesk Obsidian 18.0.41 is used:
cd C:ParallelsInstallercachepoolreleasePLESK-WIN_18.0.41_8021dist-windows
5. Unpack the MSI with the plesksrv.exe file and copy it to %plesk_bin% directory:
msiexec /a plesk-backend.msi /qb TARGETDIR=C:pleskmsi
copy "C:pleskmsiProgram FilesParallelsPleskadminbinplesksrv.exe" "%plesk_bin%"
6. Reinstall Install the missing service:
cd %plesk_bin%
plesksrv -install