Symptoms
-
Plesk is inaccessible with the below error in browser:
ERROR: Exception: Unable to get PSADb administrator password: The system cannot find the file specified. (Error code 2) at Unable to connect to pipe .pipeP_7da1332a-fe05-4176-91f2-4c4457fb71f0at<br> at (Con::ClientOverlappedPipe::create line 503)<br> at get shared instance of PleskSrvClient(PleskSrvClient::getinstance line 348)<br> at (zif_get_psadb_admin_password line 251)
Additionally, an exception has occurred while trying to report this error: Zend_Exception
No entry is registered for key ':dbAdapter' (Helper.php:68) -
The
plesk login
command returns the following error:C:> The system cannot find the file specified. (Error code 2) at Unable to connect to pipe .pipeP_949c3a9a-99ed-4320-b349-b9e25ce62cdc
at (Con::ClientOverlappedPipe::create line 518)
at get shared instance of PleskSrvClient(PleskSrvClient::getInstance line 364)
at Unable to execute CU(wmain line 85)exit status 1 -
Plesk Management Service is shown as stopped and cannot be started with the following error:
The service cannot accept control messages at this time. (Error code 1061) at ControlService 'plesksrv' with code 1
at (service::controlServie line 508)
at startService(plesksrv)(service::startService line 274)
Cause
The plesksrv.exe
process is hung.
Resolution
Warning: If the process is not shown in Task Manager, kill the process with Process Explorer Sys utility: https://docs.microsoft.com/en-us/sysinternals/downloads/process-explorer
-
Connect to the Plesk server via RDP.
-
Start Windows Task Manager and end the
plesksrv.exe
process. -
Start Plesk Management Service from Plesk Services Monitor or Windows Services.