Symptoms
-
A website hosted in Plesk redirects to the Plesk login page when accessed via HTTPS by URL https://example.com.
-
Website is opened correctly via HTTP by URL http://example.com
-
At Plesk > Tools & Settings > Customize Plesk URL is set to All domains and subdomains that resolve to the server IP address but are not used for hosting
Cause
Missing bindings in IIS server or the website has SSL/TLS Support disabled.
Resolution
Apply one of the following solutions:
Enable SSL/TLS support for the domain:
- Log into Plesk;
- Go to Domains > example.com > Hosting Settings;
- Enable the SSL/TLS support;
- Seelct a certificate (issue one if it is not available for selection)
- Click Apply.
Disable Custom Plesk URL:
-
Go to Tools & Settings > Customize Plesk URL;
-
Set No custom URLs. Only https://<server-IP-or-hostname>:8443;
-
Click Save.
Warning: After this change, Plesk will be accessible only on port 8443: https://<server-IP-or-hostname>:8443