Symptoms
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When opening the Extensions page, it fails to load with:
external server error Retry
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The following error message may be logged in
:
/var/log/plesk/panel.logCould not resolve host: ext.plesk.com
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When retrieving Plesk license keys at Tools & Settings > License Information, the operation fails with one of the the following error messages:
cURL cannot communicate with license server https://ka.plesk.com/xmlrpc (): Couldn't resolve host name(6)
Could not update the license. Make sure that connections to the license server ka.plesk.com on TCP port 443 are not blocked. See how to do so.
Cause
Corrupted Plesk extension catalog cache.
Resolution
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Connect to the Plesk server via SSH.
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Restart the sw-enging service:
# service sw-engine restart
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Try to open the extensions page.
If it fails to load, remove cache files:
# rm -rf /usr/local/psa/var/cache/https*
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Remove cache records from the Plesk database:
# plesk db "delete from PersistentCache where events like '%catalog%'"
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Restart the Plesk service:
# service sw-engine restart