Symptoms
- Plesk shows the following error:
Error: The license key is invalid. In order to use Plesk, please obtain and install a new valid license key.
The license key is intended only for use with Parallels Plesk operating inside the following virtual environments: Parallels Virtuozzo Containers, VMWare, Microsoft Hyper-V, Xen, KVM, Parallels Server. - Clicking Retrieve Keys gives the following error in
or in
/usr/local/psa/admin/logs/panel.log
:
%plesk_dir%adminlogsphp_error.log
ERR (3) [panel]: KeyUpdate Result code: 2 Unspecified error
ERR (3) [panel]: KeyUpdate Result desc: This license key is detected as terminated. No further actions with this license key are allowed
ERR (3) [panel]: KeyUpdate Result code: 2 Preparation error
ERR (3) [panel]: KeyUpdate Result desc: Cannot find a key for product "plesk-unix"
Cause
License has been terminated by the license owner
or
File
is corrupted or has improperly set permissions/owner.
'/etc/sw/keys/registry.xml'
Resolution
-
Connect to the server via SSH/RDP and reinstall Plesk micro-updates:
For Windows :
C:> %plesk_bin%ai.exe --console --select-release-current --reinstall-patch --install-component base
For Linux :
# plesk installer --select-release-current --reinstall-patch --install-component base
-
Make sure the file
exists and and has correct permissions:
'/etc/sw/keys/registry.xml'
# ll -lta /etc/sw/keys/registry.xml
-rw-rw---- 1 root swkey-data 9908 Aug 22 10:54 /etc/sw/keys/registry.xml -
Confirm that the license can be updated by Plesk Daily Maintenance script:
For Windows :
C:> %plesk_bin%php.exe -q "%plesk_dir%adminplibDailyMaintainancescript.php" -f Update
For Linux :
# /usr/local/psa/bin/sw-engine-pleskrun /usr/local/psa/admin/plib/DailyMaintainance/script.php -f UpdateKeys
- If it does not help, contact the license owner to check why license got terminated. For further details, contact Plesk Sales team.
See also :