Symptoms
When Exclude specific files from the backup is set up:
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Backup creation is configured to skip some files via Exclude specific files from the backup option in backup settings.
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Backup Manager ignores files to skip and fails with the following error:
The backup process failed: Not enough free disk space to backup selected objects. At least xxxx.xxx Mbytes free disk space is required because the free server space is not enough for the calculated size of files to backup. But the calculation ignores the configured files to skip. So it is not possible to start the backup
When remote storage is set up:
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Scheduled Plesk backups are configured to be stored Both server storage and <remote_server> at server.example.com at Tools & Settings > Backup Manager > Schedule.
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Scheduled Plesk backups are not created without any error message in Plesk.
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When creating a manual backup with the Store in option set as Both server storage and <remote_backup_storage> at server.example.com., the backup process fails with the following error message:
Error: The backup process failed: Not enough free space at the external storage to backup selected objects. At least XXXXX MBytes free disk space is required.
Cause
This is a Plesk bug with ID PPPM-8131, which will be fixed in future product updates.
Resolution
As a workaround, exclude free disk space check:
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Go to Tools & Setting > Backup Manager > Settings
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Disable the option Start the backup only if your server has the sufficient amount of free disk space.
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Configure the option Start the backup only if your server has the specified amount of free disk space (in megabytes) with the number 0
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Click OK to save the changes
If a remote backup storage is used and there is not enough free disk space to store a new Plesk backup, either add more disk space or disable this remote storage in Plesk at Tools & Settings > Backup Manager > Remote Storage Settings.