Symptoms
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When accessing Tools & Settings > Outgoing Mail Control page the following error appears:
Error: Unable to execute mailmng-outgoing: no such table: OutgoingMessages at execute console command --get-outgoing-messages-domains-stat(vconsoleapp::start line 100) at execute %plesk_dir%adminbinmailmng.exe --get-outgoing-messages-domains-stat "--stat-time=2016-07-25 08:00"(vconsoleapp::run line 117) (Error code 1)
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Cannot create a new mail account under a subscription; the account is created, but without a mailbox:
Error: mailmng-outgoing failed: ERROR:outgoing:mails.domain_id may not be NULL
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Outgoing mail does not work for one or several domains: PHP scripts may not work, Roundcube webmail returns the following error:
SMTP Error (250): Authentication failed
Cause
The outgoing mail database is corrupted.
Resolution
For Linux
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Connect to the server via SSH;
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Rename the database:
# mv /var/lib/plesk/mail/outgoing/data.db{,.bak}
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Rebuild it:
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For RHEL/CentOS/CloudLinux:
# /usr/lib64/plesk-9.0/remote_mail_restore/mail_outgoing_restore
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For Debian/Ubuntu:
# /usr/lib/plesk-9.0/remote_mail_restore/mail_outgoing_restore
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If the domain was created in Plesk in the initial attempt, delete it at Domains > select the domain example.com > Remove
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Add the domain again
For Windows:
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Connect to the server via RDP
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Delete or rename the file
%plesk_dir%admindbOutgoingMessages.db
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Run the command to rebuild it:
"%plesk_dir%adminbinmailmng.exe" --init-outgoing-messages-storage