Symptoms
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nginx fails to start with the following error:
Cannot assign requested address
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The error below may appear in the Home page in Plesk:
New configuration files for the Apache web server were not created due to the errors in configuration templates: nginx: [emerg] bind() to 203.0.113.3:443 failed (99: Cannot assign requested address) nginx: configuration file /etc/nginx/nginx.conf test failed. Detailed error descriptions were sent to you by email. To fix the issue, follow the instructions described in KB: https://support.plesk.com/hc/articles/213933865 Please resolve the issues and click here to generate broken configuration files once again or here to generate all configuration files. See the details in Configuration Troubleshooter
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A website may show outdated/old SSL certificate.
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The number of IPs registered in Plesk is higher than the actual number of IPs on the server:
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IP addresses in Plesk:
# plesk bin ipmanage -l
...203.0.113.2...
...203.0.113.3... -
IP addresses on the server:
# ip a
<...>
inet 203.0.113.2/32
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Cause
Unsynced IP address between Plesk and OS or IP address was removed/changed manually directly on the server.
Resolution
Sync IP addresses between Plesk and OS:
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Solution for Plesk Obsidian 18.0.35 and later:
- Log into Plesk.
- Go to Tools & Settings > IP Addresses.
- Press the Repair button near the IP address that is marked as broken:
Note: If the IP address that was removed from the server is not required anymore, re-assign domains to a new IP address in accordance with the following article.
Solution for Plesk Obsidian 18.0.34 and earlier
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Go to Tools & Settings > IP Addresses.
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Press the Reread IP button:
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If some IP addresses are marked as broken, either click on the Repair button to fix them or click on the Remove button if they are no longer required.
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Connect to the server via SSH.
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Re-enable nginx service:
# /usr/local/psa/admin/bin/nginxmng -d
# /usr/local/psa/admin/bin/nginxmng -e
Note: This operation can cause a significant downtime when more than 100 domains are hosted on the Plesk server, as all the configuration files will be regenerated.
Solution via CLI for Plesk Obsidian 18.0.35 and later
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Connect to the server via SSH.
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Reread IPs in Plesk:
# plesk bin ipmanage --reread
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Check IP addresses state:
# plesk bin ipmanage -l
State Type IP Clients Hosting PublicIP
0 S enp0s5:203.0.113.2/255.255.0.0 0 0
1 E enp0s5:203.0.113.3/255.255.255.255 0 1Note: State 0 means the IP address is ok, state 1 means the IP address is broken
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Repair broken IP addresses with state 1:
# plesk bin ipmanage --repair 203.0.113.3
Solution via CLI for Plesk Obsidian 18.0.34 and earlier
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Connect to the server via SSH.
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Reread IPs in Plesk:
# plesk bin ipmanage --reread
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Check IP addresses state:
# plesk bin ipmanage -l
State Type IP Clients Hosting PublicIP
0 S enp0s5:203.0.113.2/255.255.0.0 0 0
1 E enp0s5:203.0.113.3/255.255.255.255 0 1Note: State 0 means the IP address is ok, state 1 means the IP address is broken
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Repair broken IP addresses with state 1:
# plesk bin ipmanage --repair 203.0.113.3
If the IP address 203.0.113.3 is no longer required, remove it via the command below:
# plesk bin ipmanage --remove 203.0.113.3
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Re-enable nginx service:
# /usr/local/psa/admin/bin/nginxmng…