Plesk

New Public IP address in Plesk is not updated on DNS zones on slave DNS server(s)

Symptoms

Cause

Bug in the Slave DNS Manager extension with ID EXTPLESK-929, which will be fixed in future product updates.

Resolution

As a workaround, remove the DNS zone files on the slave DNS server and manually disable and re-enable the DNS for the domains at Plesk to recreate the zone files with the new public IP address.

CentOS/RHEL

  1. Connect to the Plesk (Master) server via SSH

  2. Run the following command to show a list of all domains and copy its output:

    # plesk bin domain --list > /pleskdomains.txt
    example.com
    example.net

  3. Connect to the Slave DNS server on another SSH session

  4. Replace the old IP (203.0.113.2) with the new one (203.0.113.3) at /var/named/3bf305731dd26307.nzf:

    # sed -i -e 's/'203.0.113.2'/'203.0.113.3'/g' /var/named/3bf305731dd26307.nzf

  5. Take the output copied from step #2 and paste into it:

    # cat /pleskdomains.txt
    example.com
    example.net

  6. Run the following commands to remove the zone files of Plesk domains from the slave DNS server:

    # for i in $(cat /pleskdomains.txt); do rm -f /var/named/$i ; done

  7. Restart DNS service on slave DNS server:

    # systemctl restart named

    Note: Repeat steps 3-7 on each of connected slave DNS servers.

  8. Return to SSH console of Plesk (Master)

  9. Turn on/off DNS service for each domain:

    # for i in $(cat /pleskdomains.txt); do plesk bin dns --off $i; plesk bin dns --on $i; done

Debian/Ubuntu

  1. Connect to the Slave DNS server via SSH.

  2. Delete information about zone example.com:

    # rndc delzone -clean example.com

  3. Check that the information about zone was removed. The command should return empty output:

    # named-nzd2nzf /var/cache/bind/_default.nzd | grep example.com

  4. Log in to Plesk and sync DNS zones under Extensions > My Extensions > Slave DNS Manager > Resync.

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