Symptoms
-
Migration pre-check shows the error:
Detected potential issues
|
|- error: A system user with the name jdoe already exists on the destination server.
|
| Affected subscriptions:
| - example.com
|
| Please rename the existing system user on the destination server.
|
`- Subscription 'example.com'
| Please rename the existing system user on the destination server. -
Or the following warning can be found in migration [Details]:
Unable to restore the original username for the system user of the subscription example.com: a system user named jdoe is already present on target panel. For this reason, the subscription owner will not be able to log in to FTP under the original username.
Notify the subscription owner of the new FTP username: sub_1783193419. The subscription owner can change this username on target panel.
Cause
The error is self-explanatory: user jdoe already exists on the target server.
Subscription users must have unique names.
Resolution
-
This warnings can be safely ignored. Just note the new changed system user name when migration is done. It can be changed after migration at Subscriptions > example.com > Web Hosting Access.
-
As an alternative solution, rename the existing system user on the destination server.
Note: The commands below applicable to Windows and Linux servers.
-
Find the subscription that has system user user_name if it is not clear:
-
C:> plesk db
-
Execute the following query to find subscription:
select login, home from sys_users where login='jdoe';
-
Log into Plesk and browse to
-
Subscriptions > example.com > FTP Access
or - Subscriptions > example.com > Web Hosting Access
And rename the existing user mentioned in the warning.
-
Subscriptions > example.com > FTP Access
-
Re-run migration.
-