Symptoms
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Mail could not be delivered to remote server from Plesk, it is stuck in the outgoing queue.
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%plesk_dir%Mail ServersMail EnableLOGGINGSMTPSMTP-Debug-<datetime>.log
file contains the following errors:ME-E0124: Error (1460): Could not resolve MX list for domain [example.com]
ME-E0042: - SMTP Connection DNS Server could not resolve domain name (example.com) in a timely fashion. Check DNS Server settings.
ME-E0042: [71F2BE266CCF446CA0B9225A0DD2D496.MAI] - SMTP Connection DNS Server could not resolve domain name (example.com) in a timely fashion. Check DNS Server settings.
ME-E0059: [71F2BE266CCF446CA0B9225A0DD2D496.MAI] Message Delivery Failure. Attempt (0): Could not connect to mail server for domain (example.com). The remote mail server could not be contacted at this time. Message has been requeued. -
The recipient's domain name example.com can be resolved externally. For instance:
C:> nslookup example.com
Address: 203.0.113.2and its MX record can be verified as described in this article.
Cause
DNS server configured in MailEnable could not resolve recipient domain IP address.
Resolution
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Connect to the server via RDP.
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Go to MailEnable console > Servers > localhost > Services and Connectors > SMTP > Properties > General tab.
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Configure DNS servers IP addresses. For example, Google DNS servers IP could be added:
8.8.8.8
or4.4.4.4
:Note: SMTP server must be restarted to apply changes, if any (Servers > localhost > Services and Connectors > SMTP > Stop/Start).
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If the error still persists, make sure that the server is able to resolve any public host:
C:> ping google.com
Ping request could not find host google.com. Please check the name and try again.If the output is like above, contact the network administrator.