Plesk

Mail sent to Postfix default accounts is routed to Plesk Administrator’s email

Applicable to:

  • Plesk for Linux

Symptoms

Cause

This behavior is by design: In the following output, it can be seen that all emails sent to the accounts mentioned (for example root@localhost.localdomain) are forwarded to Plesk Administrator email address (for example pleskadmin@example.com):

postmap -s /var/spool/postfix/plesk/aliases
drweb pleskadmin@example.com
kluser pleskadmin@example.com
postmaster pleskadmin@example.com
root pleskadmin@example.com
anonymous pleskadmin@example.com
drweb-daemon pleskadmin@example.com
ailer-daemon pleskadmin@example.com
mailman pleskadmin@example.com

Resolution

To change this behavior:

  1. Connect to the server via SSH;

  2. Modify /etc/aliases file to forward all messages from desired accounts to another mailbox (for example john.doe@example.com).

    For instance, for the account root@localhost.localdomain, add the following line into the /etc/aliases file:

    root: john.doe@example.com

  3. Run the following command:

    # postalias /etc/aliases

  4. Verify that the setting applied:

    # postmap -s /etc/aliases | grep root

Note: This will not affect accounts created in Plesk with the name root@domainname.com, but if the mailbox does not exist then the message will be forwarded to john.doe@example.com instead of the Plesk Administrator email address.

Exit mobile version