Plesk

Log rotation is not working for a particular domain while works correctly for others

Symptoms

Causes

The rotation configuration file is missing for the domain.

Resolution

Recreate tbe log rotation configuration file for the affected domain:

Note: The solution below works only for Active domains. Suspended or Disabled domains will not be affected.

  1. Go to Plesk > Domains > example.com > Logs > Log Rotation (button).

  2. If Log rotation checkbox is:

    Turned off

    2.1 Enable it from the checkbox and click OK ;

    Turned on

    2.1. Disable it unmarking the checkbox and click OK.

    2.2. Click on Log Rotation button again.

    2.3. Set Log rotation checkbox back on and click on OK.

  3. Make sure that log rotation configuration file for the domain example.com has appeared in the /usr/local/psa/etc/logrotate.d/ folder:

    # ls -la /usr/local/psa/etc/logrotate.d/ | grep example.com
    -rw-r--r-- 1 root root 503 Dec 1 17:39 example.com

Alternatively, it is possible to recreate the missing file via the command line:

For one domain

  1. Connect to the server via SSH.

  2. Execute the command below for the affected domain:

    # plesk bin domain -u example.com -log-rotate true

For all domains

  1. Connect to the server via SSH.

  2. Activate log rotation for all domains:

    # plesk bin domain -l| while read dom_name; do plesk bin domain -u $dom_name -log-rotate true; done

Additional info

Logs are no longer rotated properly on some subscriptions

How to change log rotation settings for all domains at once?

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